WordPressで「画像を切り抜く際にエラーが発生しました。」と表示される。

スポンサードリンク

WordPressのテーマを人気らしいSTINGER5に変更してみました。
STINGER5には、あんまり好きじゃないヘッダー画像が必要みたいなので、ベトナム・ホイアンのお店のランタンの画像を使ってみたんですが、問題が発生しました。

ヘッダー画像のアップロードの時にこんなエラーが発生しました。

画像を切り抜く際にエラーが発生しました。

最初、画像のサイズや、画像名、拡張子が悪いのかと思っていろいろ試してみたのですが、改善されません。別に切り抜かなくてもいいのになーと思いましたが、切り抜かないと設定できないようです。

あれこれ調べてたらCentOSの場合、サーバでphp-gdというパッケージが入っていないとエラーになるという情報を得て

sudo yum install php-gd

してみたんですが、どうもphp56-commonとConflictを起こすということで入ってくれません。
一旦、

スポンサードリンク

sudo yum remove php56-common
sudo yum install php-gd
sudo /etc/rc.d/init.d/httpd restart

してみたら、インストールはできたものの、ブログが落ちてしまいました。
これじゃ意味ないということで、

sudo yum install php56-common

しても戻らなくなってしまい、


sudo yum history list
sudo yum history undo 5

でremoveする直前まで戻そうと思ったら、失敗して

sudo yum remove php-gd

してから

sudo yum history list
sudo yum history undo 5

してなんとか元に戻りました。

結局、どうするべきだったかというと

sudo yum install php56-gd

とphp56に合わせたら入れることができました。
やれやれ。

この辺のパッケージ関連の不具合とか、非エンジニアのWordPress使いはどうやって解決してるんでしょう。

スポンサードリンク

コメントを残す